Pagination error with API calls that search for projects

Incident Report for status.xtm.cloud

Resolved

This incident has been resolved.
Posted Jan 22, 2024 - 08:21 CET

Monitoring

Fix has been deployed to 13.5 and is working.
Fix to be delivered to affected servers.
Posted Jan 17, 2024 - 15:58 CET

Identified

The issue has been identified and the fix is currently awaiting tests.
Posted Jan 17, 2024 - 10:31 CET

Investigating

API calls with the "page" parameter result in the below error when the value used is out of bounds and would otherwise result in an empty list of projects.
{
"reason": "Request parameter seems to be invalid.",
"invalidParameter": "fromIndex(10) > toIndex(9)"
}

Affected API calls
REST
GET /projects
POST /projects/search

SOAP
findProject
Posted Jan 16, 2024 - 16:32 CET
This incident affected: TCL1 and US Cloud.